Pataisymas: .NET Framework 4.7 nepalaikoma šioje operacinėje sistemoje

Pataria: Spauskite Čia Norėdami Nustatyti Windows Klaidų Ir Optimizuoti Sistemos Veikimą

.Net Framework yra programavimo infrastruktūra, kurią įdiegė „Microsoft“. Norėdami paleisti įvairias programas ir paslaugas, jums reikės „.Net Framework“. Daugelis programų, kurioms reikalinga .Net Framework, taip pat pateikiamos kartu su jos diegimo failais. Taigi, diegiant programą, jis bus automatiškai įdiegtas jūsų sistemoje. Diegdami programą galite pamatyti klaidą „.NET Framework 4.7 nepalaikoma šioje operacinėje sistemoje“. Ši klaida neleis sėkmingai įdiegti programos. Šią klaidą galite pamatyti bandydami įdiegti .Net Framework kaip atskirą programą / paslaugą.

Šios klaidos priežastis yra ta pati, kuri paminėta klaidos pranešime. Nors „.Net Framework“ palaikoma „Windows 10“, tačiau jis nesuderinamas su visomis „Windows 10“ versijomis. Taigi, jei matote šį pranešimą, greičiausiai šios klaidos priežastis yra ta, kad naudojate „Windows 10“ versiją, nėra suderinamas su .Net Framework.

1 būdas: atnaujinkite „Windows 10“

Vienintelis šios problemos sprendimas yra tiesiog atnaujinti „Windows 10“. Patariama patikrinti, ar nėra „Windows“ naujinimų, net jei naudojate naujausią „Windows 10“ versiją. Kadangi problemą sukelia nesuderinama operacinė sistema, įdiekite visus galimus „Windows 10“. atnaujinimai greičiausiai išspręs problemą. Taip pat galite patikrinti tikslią „Windows 10“ versiją ir versiją, kurios reikalauja „.Net Framework“, atlikdami toliau nurodytus veiksmus.

  1. Laikykite paspaudę „ Windows“ klavišą ir paspauskite R
  2. Įveskite winver ir paspauskite Enter

  1. Jūsų versija turėtų būti paminėta naujai atidarytame lange. Skaičius po versijos (antroje eilutėje) yra jūsų versijos numeris. Skaičius turėtų būti 1507 arba 1709. Pirmieji 2 skaitmenys yra metai, o antrieji 2 reiškia mėnesį. Taigi, jei turite 1709 versiją, tai reiškia, kad naudojate versiją, išleistą 2017 m. Rugsėjo mėn

  1. Dabar jūs turite įsitikinti, kad turite „Windows 10“ versiją, suderinamą su .Net Framework. Spustelėkite čia ir spustelėkite Sistemos reikalavimai

Jei pažvelgsite į „ Palaikomos operacinės sistemos“ skyrių, sakoma, kad „ Windows 10 Anniversary Update“ ir „ Windows 10 Creators“ atnaujinami . Kadangi daugelis žmonių nėra susipažinę su versijų numeriais, susijusiais su jubiliejaus ir kūrėjų atnaujinimais, mes juos paminėjome žemiau

  • Lapkričio atnaujinimas (1511)
  • Jubiliejaus atnaujinimas (14393)
  • Kūrėjų atnaujinimas (1703)
  • Rudens kūrėjų atnaujinimas (1709)
  • Pavasario kūrėjų atnaujinimas (1803)

Kaip matote, jubiliejinio atnaujinimo versija yra 14393, o kūrėjų atnaujinimo versija - 1703. Taigi, jei jūsų versija yra žemesnė nei 14393, tuomet „Windows 10“ negalėsite įdiegti .Net Framework 4.7. Dabar tiesiog atnaujinkite „Windows“ ir įsitikinkite, kad turite naujausią „Windows 10“ versiją, ir bandykite dar kartą.

Įdomios Straipsniai